Page 1 of 1

GPIO crashing

Posted: Fri Oct 28, 2016 7:19 am
by sam3481
My current setup is a MS3x can attached to a GPIO running a 2JZ vvti and toyota a340 transmission.

The setup has been working great for a few months but earlier this week after I had made some changes to the transmission shift mapping I thought it had saved the map. I had parked the car and come back a few hours later when I tried to take off the car tried to start off in 3rd gear.. I attached the computer and Megatune said there was a protocol error communicating with the GPIO. Then a CAN device firmware signature mismatch. I had not changed anything that significant so I am not sure what was causing this.. I gave up and reflashed the GPIO and it re connects like normal but when I try to load my old map or even try to load a much older map into the GPIO it looks like it loads fine and requests a power cycle.. Once I power cycle the car the gpio comes back up very briefly then goes offline. If I power cycle the car again and try to test the com port it comes back successful but then gives me a warning

Error reading data from Transmission after 4 attempts
Error message returned:
Could not process Comminstruction
Error written to log.
Timeout after:356ms. requested timeout:230, Expected bytes:1016, bytes read:0

Application will not go offline...

Any ideas would be greatly appreciated.